Spectrum 10.2.x MIB Tools does not finish loading

Document ID : KB000076391
Last Modified Date : 03/04/2018
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Issue:
Users are able to launch MIB Tool, but it never finishes loading and does not display any MIB information. Occasionally the users would see an message that OneClick was running low on memory and need to close.
Cause:
We checked the OneClick Web Server's "Administration Pages" and found OneClick was using memory allocation settings that appear to be from an older release of Spectrum.
Resolution:
To check the OneClick Web Server's memory configurations:
  1. Open a Web Browser and navigate to the OneClick Wen Page.
  2. Select the "Administration" tab to navigate to the Administration Pages
  3. Select the "OneClick Client Configuration" link on the left-hand side of the page.
  4. Check the "Java Memory Usage" settings and ensure the "Maximum Client memory Usage (megabytes) is set appropriately for your environment.
User-added image
Note: If the maximum memory is set too high, some users may not be able to launch the OneClick client.
  1. Select the "Web Server Memory" link on the left-hand side of the page.
  2. Check the "Maximum Memory the Server Can Use (In MB)" is set appropriately for your environment.
 User-added image
Note: Setting this value too high (more than the available memory for the server), can cause Tomcat to fail to start.
  1. Save the changes and restart Tomcat.

After making modifications to the allocated tomcat memory from 1280 MB to 4096 MB (10.2.x default setting), and the OneClick client max memory from 512 MB to 1024 (10.2.x default setting), MIB Tools now loads and displays the MIBs.