Spectrum 10.2 Processd Install Fail

Document ID : KB000112243
Last Modified Date : 06/09/2018
Show Technical Document Details
Issue:
Install runs but does not complete successfully. The post Installation log located in <SPECROOT>/Install/Tools/LOGS is showing mesages like the following:

SpectroSERVER.exe Validation Complete
Creating shortcut C:\ProgramData\Microsoft\Windows\Start Menu\Programs\CA\SPECTRUM Control Panel.lnk for D:\Spectrum\bin\SCP
Starting tomcat for axis2 deployment.
Stopping tomcat after axis2 deployment.
Copying utilsrv.jar to axis2 web-app for NetQos logging.
Requesting installation of service: "SPECTRUM Process Daemon" error: Unable to authenticate user. Please verify username and password. error: service refused to be installed Requesting start of service: "SPECTRUM Process Daemon" StartService error: 0x6, this service isn't currently installed ** Error during starting processd
Environment:
Windows OS
Spectrum 10.2.0
Cause:
The initial Spectrum Admin user has special characters in the password. These are preventing Processd from installing properly. 
 
Resolution:
Spectrum Install user has special characters in the password "@" and "%" this can prevent processd to install. There are two options:

1. Edit the password and change/remove the special characters and Spectrum should install. 
2. Use quotes for the password in the Install dialog - e.g.: "pa$$word"
Additional Information:
Here are a few more KB's related to processd install issues and setting processd password: 

https://comm.support.ca.com/kb/spectrum-installation-requirements-for-windows/kb000045037
https://comm.support.ca.com/kb/processd-could-not-start-in-ca-spectrum-101-version/kb000041303 
https://comm.support.ca.com/kb/processd-not-starting-on-oneclick-server-spectrum-install-owner-password-expired/kb000111121