SpectroSERVER model activation taking a long time due to CsIHVoiceApp activation

Document ID : KB000007891
Last Modified Date : 14/02/2018
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Issue:

When starting the SpectroSERVER, model activation takes a very long time.  If the mdlact_debug=true entry is in the $SPECROOT/SS/.vnmrc, debug will output to the $SPECROOT/SS/VNM.OUT showing that the CsIHVoiceApp is problematic.

Cause:

During SS activation the CsIHVoiceApp reads the following attributes:

 

callActivePeerSubAddress 1.3.6.1.2.1.10.21.1.3.1.1.4

cvCallActiveConnectionId 1.3.6.1.4.1.9.9.63.1.3.1.1.1

cvVoIPCallActiveConnectionId 1.3.6.1.4.1.9.9.63.1.3.2.1.1 

 

These tables may have thousands or millions of entries. Spectrum does not actively monitor this table, so during SS startup, the table is read and stored to memory but the information is not needed by Spectrum.  

Resolution:

This is tentatively scheduled to be fixed in CA Spectrum release 10.2.2 and 10.3 due out later this year.  The fix will remove the polling of the above mentioned attributes during model activation.

A manual workaround is to delete the following file and then restart the SpectroSERVER process:

*nix:

$SPECROOT/SS/Modules/libcvoicess.dll.so.1

Windows:

$SPECROOT/SS/Modules/libcvoicess.dll