SpectroSERVER crashed with status TERMINATED

Document ID : KB000007622
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Spectrum crashed creating .dmp and .mdmp files in the %SPECROOT%/SS/support folder with status TERMINATED as below:

scp error.png

 

The VNM.OUT file contains the below information:

Jul 03 15:48:23 : SLMIHResCollector::send_resource_value_change leaving

Jul 03 15:48:23 :     send resource value change watched attr id 0x1000a watched value 0

Jul 03 15:48:23 :   initialize_resource_collector monitor start monitoring resource mh 0x202ba7

Jul 03 15:48:23 : SLMIHResCollector::start_monitoring_resource entered

Jul 03 15:48:23 :   start_monitoring_resource res_collector 0x244383 resource_handle 0x202ba7

Jul 03 15:48:23 :   start_monitoring_resource attr_id 0x1000a watched_value 0x0

Jul 03 15:48:23 :   start_monitoring_resource is_managed reg_watch --- res_collector_handle 0x244383 --- resource_handle 0x202ba7

Jul 03 15:48:23 :   start_monitoring_resource resource reg_watch --- 1

Jul 03 15:48:23 : SLMIHResCollector::register_attribute_watch entered

Jul 03 15:48:23 : res_collector 0x244383 resource_handle 0x202ba7 attr_id 0x1000a

Jul 03 15:48:23 : SLMIHResCollector::register_attribute_watch CONDITION

Jul 03 15:48:23 : SLMIHResCollector::register_attribute_watch leaving

Jul 03 15:48:23 : SLMIHResCollector::start_monitoring_resource leaving

Jul 03 15:48:23 :   initialize_resource_collector monitor send resource value change mh 0x202ba7

Jul 03 15:48:23 : SLMIHResCollector::send_resource_value_change res_collector mh 0x244383 resource_handle 0x202ba7 new val 0 old val 0

Jul 03 15:48:23 :   send_resource_value_change landscape is down 0x100775

       Percentage of models activated : 29%    

SPC-SHD-29021: 

**************************************************************************

The following output is intended to facilitate debugging, please forward

to CA technical support.  The files listed are not part of the customer

installation of SPECTRUM.

**************************************************************************

 

An application fault has occurred.

Saved full memory diagnostic file to 'D:\win32app\Spectrum\SS\support\SpectroSERVER.mdmp'

Saved compact diagnostic file to 'D:\win32app\Spectrum\SS\support\SpectroSERVER_20170703_1550.dmp'

Appending thread state information to .moot.trace file

Exiting.

 

The extracted dump file is as below:

 

FAULTING_IP:

 

libmdlsvint!IHSerialNumberReg::trig_model_activate+33 [d:\spectrum\10.1.1\cm\windows\ptf_10.1.160\mdlsv.a\intel\ihserialnumberreg.cc @ 125]

000007fe`e9bc44c7 833800          cmp     dword ptr [rax],0

 

EXCEPTION_RECORD:  ffffffffffffffff -- (.exr 0xffffffffffffffff)

ExceptionAddress: 000007fee9bc44c7 (libmdlsvint!IHSerialNumberReg::trig_model_activate+0x0000000000000033)

   ExceptionCode: c0000005 (Access violation)

  ExceptionFlags: 00000000

NumberParameters: 2

   Parameter[0]: 0000000000000000

   Parameter[1]: 0000000000000000

Attempt to read from address 0000000000000000

 

DEFAULT_BUCKET_ID:  NULL_POINTER_READ

 

PROCESS_NAME:  SpectroSERVER.exe

 

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

 

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

 

EXCEPTION_PARAMETER1:  0000000000000000

 

EXCEPTION_PARAMETER2:  0000000000000000

 

READ_ADDRESS:  0000000000000000

 

FOLLOWUP_IP:

libmdlsvint!IHSerialNumberReg::trig_model_activate+33 [d:\spectrum\10.1.1\cm\windows\ptf_10.1.160\mdlsv.a\intel\ihserialnumberreg.cc @ 125]

000007fe`e9bc44c7 833800          cmp     dword ptr [rax],0

 

FAULTING_THREAD:  0000000000002488

 

PRIMARY_PROBLEM_CLASS:  NULL_POINTER_READ

 

BUGCHECK_STR:  APPLICATION_FAULT_NULL_POINTER_READ

 

LAST_CONTROL_TRANSFER:  from 000007fee9d2ad68 to 000007fee9bc44c7

 

STACK_TEXT: 

00000000`65d1f920 000007fe`e9d2ad68 : 00000000`65d1f9e8 00000000`65d1fbac 00000000`00000000 00000000`177e20c0 : libmdlsvint!IHSerialNumberReg::trig_model_activate+0x33 [d:\spectrum\10.1.1\cm\windows\ptf_10.1.160\mdlsv.a\intel\ihserialnumberreg.cc @ 125]

00000000`65d1f950 000007fe`e9d9899e : 00000000`68236270 00000000`177e20c0 00000000`177e20c0 00000000`39e7b4b8 : libsskrnl!CsIHActWatcher::notify+0x144 [d:\spectrum\10.1.1\cm\windows\ptf_10.1.160\sscor.a\trigger\src\csihactwtch.cc @ 124]

00000000`65d1fb30 000007fe`e9d09b91 : ffffffff`fffffffe 00000000`40916c70 00000000`1b6689c0 00000000`02e682f0 : libsskrnl!CsModel::activate_model+0x1f2 [d:\spectrum\10.1.1\cm\windows\ptf_10.1.160\sscor.a\lscpe\src\csmodel2.cc @ 2063]

00000000`65d1fe20 000007fe`f27634f3 : 00000000`1b6689c0 00000000`00000000 00000000`00000000 00000000`02e682f0 : libsskrnl!CsActivateScheduler::process_queued_work+0x2d [d:\spectrum\10.1.1\cm\windows\ptf_10.1.160\sscor.a\trigger\src\csactsched.cc @ 189]

00000000`65d1fe50 00000000`1b6689c0 : 00000000`00000000 00000000`00000000 00000000`02e682f0 00000000`40916c70 : libwkmgr+0x34f3

00000000`65d1fe58 00000000`00000000 : 00000000`00000000 00000000`02e682f0 00000000`40916c70 000007fe`f276279b : 0x1b6689c0

 

 

STACK_COMMAND:  ~0s; .ecxr ; kb

 

FAULTING_SOURCE_CODE: 

No source found for 'd:\spectrum\10.1.1\cm\windows\ptf_10.1.160\mdlsv.a\intel\ihserialnumberreg.cc'

 

 

SYMBOL_STACK_INDEX:  0

 

SYMBOL_NAME:  libmdlsvint!IHSerialNumberReg::trig_model_activate+33

 

FOLLOWUP_NAME:  MachineOwner

 

MODULE_NAME: libmdlsvint

 

IMAGE_NAME:  libmdlsvint.dll

 

DEBUG_FLR_IMAGE_TIMESTAMP:  5893dd0b

 

FAILURE_BUCKET_ID:  NULL_POINTER_READ_c0000005_libmdlsvint.dll!IHSerialNumberReg::trig_model_activate

 

BUCKET_ID:  X64_APPLICATION_FAULT_NULL_POINTER_READ_libmdlsvint!IHSerialNumberReg::trig_model_activate+33

 

WATSON_STAGEONE_URL:  http://watson.microsoft.com/StageOne/SpectroSERVER_exe/10_1_1_0/56e70c37/libmdlsvint_dll/10_1_1_0/5893dd0b/c0000005/001444c7.htm?Retriage=1

 

 

Followup: MachineOwner

Environment:
Spectrum 10.1.1 running on all supported Platforms
Cause:

Some devices returning serial number as null

Resolution:

Please open case with Support to obtain PTF_10.1.175 which fixes null serial number issue.

Please note, SPECTRUM 10.01.01, and PTF_10.1.160 are the prerequisites for installation of this patch.

Refer the Patch Release Notes before installing the patch.

The issue has been taken care in Spectrum release 10.2