Solve:Operations Automation Install Error in CA Chorus Software Manager (CSM)

Document ID : KB000103767
Last Modified Date : 29/06/2018
Show Technical Document Details
Issue:
Error using CA Chorus Software Manager (CSM) to install Solve:Operations Automation Release 11.9.

The APPLY is doing this:
 
> APPLY
> SELECT(CC2D710,CC2D71E,CC2HB90,CC2D71H)
> COMPRESS(ALL) .
 
It fails in the linkedit of NM022007 because of:
 
> IEW2322I 1220 7569 NAME NM022007(R) MAX ACCEPTABLE RC=08
> IEW2439E 9228 THE AMODE OF THE REFERENCING ESD JNI_CreateJavaVM DOES NOT MATCH THAT SPECIFIED ON THE IMPORT STATEMENT.
 
At the start of the linkedit it is doing an import like this:
 
> IEW2322I 1220 59 IMPORT CODE64,'libjvm.so','JNI_CreateJavaVM'
 
The only java I have on my z/OS system is 64bit, hence my LIBJVM DDDEF looks like:
 
> LIBJVM LIBJVM PATH '/usr/lpp/java/J7.1_64/bin/classic/'
 
Resolution:
In CA Chorus Software Manager (CSM),  Solve Operations Automation Release 11.9 no longer uses SSL Components, it now uses AT-TLS.
You don’t need to install the SSL Components anymore.
Also Solve Operations Automation Release11.9 also does not use JAVA 64bit.
In CA Chorus Software Manager (CSM) just select Solve Operations Automation Release 11.9 and not the other SSL Components.