SOI UI Server Not Coming Up

Document ID : KB000124967
Last Modified Date : 21/01/2019
Show Technical Document Details
Issue:
After re-installing SOI in a lab environment scheduled for lock-down testing the SOI UI Manager service is running but the webpages are not fully coming up. Looking over the SOI UI Debug page under "Triage Tests" there are 6 servlets still waiting to complete even though teh service has been running for over an hour. No Services have been stood up in SOI yet either. Furthermore, when looking over the soiuis logs the following error is repeated in the file: 2019-01-18 17:57:39,659 ERROR [ServletInit] ?.?(?) - com.aprisma.util.net.http.HttpRecoverableException: Could not parse the status line from the response: connection lost 2019-01-18 17:57:39,659 ERROR [ServletInit] ?.?(?) - at com.aprisma.util.net.http.HttpMethod.readStatusLine(HttpMethod.java:1541) 2019-01-18 17:57:39,659 ERROR [ServletInit] ?.?(?) - at com.aprisma.util.net.http.HttpMethod.readResponse(HttpMethod.java:1499) 2019-01-18 17:57:39,659 ERROR [ServletInit] ?.?(?) - at com.aprisma.util.net.http.HttpMethod.processRequest(HttpMethod.java:542) 2019-01-18 17:57:39,660 ERROR [ServletInit] ?.?(?) - at com.aprisma.util.net.http.HttpMethod.execute(HttpMethod.java:966) 2019-01-18 17:57:39,660 ERROR [ServletInit] ?.?(?) - at com.aprisma.spectrum.app.web.domain.HttpServerDomain.connect(HttpServerDomain.java:224) 2019-01-18 17:57:39,660 ERROR [ServletInit] ?.?(?) - at com.ca.sam.web.domain.SamServerDomainList$SamServerDomain.connect(SamServerDomainList.java:51) 2019-01-18 17:57:39,660 ERROR [ServletInit] ?.?(?) - at com.ca.sam.web.domain.SamServerDomainList.addManagerServer(SamServerDomainList.java:235) 2019-01-18 17:57:39,661 ERROR [ServletInit] ?.?(?) - at com.ca.sam.web.domain.SamServerDomainList.start(SamServerDomainList.java:183) 2019-01-18 17:57:39,661 ERROR [ServletInit] ?.?(?) - at com.aprisma.spectrum.app.util.context.ContextFactory.threadSafeStartContextObject(ContextFactory.java:256) 2019-01-18 17:57:39,661 ERROR [ServletInit] ?.?(?) - at com.aprisma.spectrum.app.util.context.ContextFactory.getContextObject(ContextFactory.java:162) 2019-01-18 17:57:39,661 ERROR [ServletInit] ?.?(?) - at com.aprisma.spectrum.app.web.security.EEMGlobalAccessPrivilegeManager.start(EEMGlobalAccessPrivilegeManager.java:1290) 2019-01-18 17:57:39,662 ERROR [ServletInit] ?.?(?) - at com.aprisma.spectrum.app.util.context.ContextFactory.threadSafeStartContextObject(ContextFactory.java:256) 2019-01-18 17:57:39,662 ERROR [ServletInit] ?.?(?) - at com.aprisma.spectrum.app.util.context.ContextFactory.getContextObject(ContextFactory.java:162) 2019-01-18 17:57:39,662 ERROR [ServletInit] ?.?(?) - at com.aprisma.spectrum.app.web.servlet.UIServerInitServlet.startComponents(UIServerInitServlet.java:106) 2019-01-18 17:57:39,662 ERROR [ServletInit] ?.?(?) - at com.aprisma.spectrum.app.web.servlet.UIServerInitServlet.initialize(UIServerInitServlet.java:70) 2019-01-18 17:57:39,662 ERROR [ServletInit] ?.?(?) - at com.ca.sam.common.HttpServlet$InitTask.run(HttpServlet.java:231) 2019-01-18 17:57:39,663 ERROR [ServletInit] ?.?(?) - at com.aprisma.util.thread.JobQueue.runJobThread(JobQueue.java:407) 2019-01-18 17:57:39,663 ERROR [ServletInit] ?.?(?) - at com.aprisma.util.thread.JobQueue.access$400(JobQueue.java:43) 2019-01-18 17:57:39,663 ERROR [ServletInit] ?.?(?) - at com.aprisma.util.thread.JobQueue$JobRunnable.run(JobQueue.java:136) 2019-01-18 17:57:39,663 ERROR [ServletInit] ?.?(?) - at java.lang.Thread.run(Thread.java:745)
Environment:
SOI 4.0
SOI 4.2
 
Cause:
The UI was unable to connect to the SOI manager because the manager was set to use https only. 
By default, SOI UI is set to use http.
Resolution:
Need to edit \CA\SOI\SamUI\webapps\sam\server-config.xml 
Change 
<protocol>http</protocol> 
to 
<protocol>https</protocol> 

Restart the CA SAM User Interface Server