SOI Stopped working due to the corruptions in activemq-data directory

Document ID : KB000044738
Last Modified Date : 14/02/2018
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Symptoms

SOI console stops publishing the alerts from the connectors.

In the SOI manager server, if you find the following errors in \SOI\log\ifw.log.

Caused by: javax.jms.JMSException: Could not connect to broker URL: tcp://<SOI-manager-host>:61616. Reason: java.net.ConnectException: Connection refused: connect at org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:35) 
at org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:286) 
at org.apache.activemq.ActiveMQConnectionFactory.createTopicConnection(ActiveMQConnectionFactory.java:215) 
at com.ca.sam.ifw.api.jms.JMSImpl.msgBusCreateTopicConnection(JMSImpl.java:390) 

Environment:  

SOI 3.1, 3.2, 3.3, 4.0, 4.1.

Cause: 

By default, there are four files in SOI\tomcat\webapps\activemq-web\activemq-data on the SOI manager.   There are some corruptions in this directory to cause SOI manager stop publishing the alerts.

Resolution/Workaround:

1. Stop all the SOI services on SOI manager.

2. On the SOI manager, please remove all the files under \SOI\tomcat\webapps\activemq-web\activemq-data.

3. Start all the SOI services on SOI manager.