Software Delivery cannot shutdown machine after last job

Document ID : KB000030100
Last Modified Date : 14/02/2018
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Problem

  • When defining the Procedure option "Boot Level After Execution = Shutdown machine after last job" the computer fails to shutdown as expected.

Environment

  • Client Automation 12.5 and above

Cause

  • 12.5 introduced this Boot Level option and documented it in the release notes

    Shut Down a Computer after Last SD Job

    You can now decide to shut down a target computer after completion of the last software delivery job. Software delivery provides the shutdown-related job and calendar options. A combination of the job and calendar options controls the shutdown behavior of the target computer. You can use these options to decide when to shut down a computer, whether to shut it down or not, or how to define non-conflicting time ranges within which it is appropriate to shut down. This functionality helps ensure that the target computers use power in an optimal manner and support the defined Green IT policies of the organization.
  • The default is to not allow the shutdown

Solution

This is controlled by the configuration policy
DSM/Common Components/CAF/shutdown/Software Delivery: Shutdown Behaviour

This policy has the following description

Shutdown behaviour for this computer.

  • By default, if NOT set, it is 0 (zero) indicating that Shutdown is never allowed for this computer.
  • 1 indicates computer will be shutdown if requested in job options.
  • 2 indicates computer will be shutdown if requested by calendar.
  • 3 indicates computer will be shutdown if either job option or calendar request shutdown,
  • 4 indicates computer will be shutdown only if both job option and calendar request shutdown.

If not using a calendar then a value of 1 or 3 will allow the computer to shutdown as required