SNMPcollector Devices Stuck in "Discovery Pending"

Document ID : KB000005843
Last Modified Date : 14/02/2018
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Issue:

Snmpcollector Devices Stuck In "Discovery pending"

Cause:

The devices being discovered by snmpcollector should only be in a pending state for a short while. In the snmpcollector database, each device being discovered has a DiscoveryReason.  This will look like, "Device was added to inventory", "Scheduled rediscovery", etc.  Without a DiscoveryReason, the device will never leave "Discovery pending" status.

Resolution:

To evaluate and resolve this issue, please do the following while the problem is happening:


1. Create a database back up by copying the ...Nimsoft\probes\network\snmpcollectorcheck\SnmpCollector.mv.db file.

2. In a web browser on the snmpcollector server, go to http://localhost:9715/database

3. Enter the snmpcollector database management interface using the username "sa" and no password

4. Run the following query:
select * FROM SNMPDEVICE where DISCOVERYSTATE='DISCOVERY_PENDING' and DISCOVERYREASON='';

5. If the above query returns any rows, the DISCOVERYREASON is empty for these devices.  This problem can be resolved by updating the DB to set a valid reason. This can be done by updating the DISCOVERYREASON to "User request" with the following query:
update SNMPDEVICE set DISCOVERYREASON='User request' where DISCOVERYSTATE='DISCOVERY_PENDING';

6. The discovery process can be monitored with the following query.  After the update query, this count number should begin to decrease.
select count(*) FROM SNMPDEVICE where DISCOVERYSTATE='DISCOVERY_PENDING'