SMARTTRACE GENERATES NO RECORDS

Document ID : KB000094739
Last Modified Date : 15/11/2018
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Issue:
SmartTrace is set up and activated but it generates no output--it was even checked overnight.
Cause:
1. The following messages appear on the NetMaster SSI log:

NFSU81 TRACE NMI SUBTASK INIT FOR STACK TCPIPD1 FAILED, RC: R15=00000000 CODE: 8 SUBCODE: 0
NFSU84 TRACE NMI AUTHORIZATION ERROR, EZBRCIFR FUNCTION: OPEN RETVAL: FFFFFFFF RETCODE: 0000006F RSNCODE: 786000DC


2. $$SYSPRO may show the following messages

IPDI52H0 Checking IBM TCPIP SMF Configuration 
IPDI52J4 Note: TCPIP - Stack Configuration has 118 Subsection 
IPDI52H5 Error: TCPIP - Stack Configuration for SMF record 119 does not have TCPINIT subrecord specified 
IPDI52H5 Error: TCPIP - Stack Configuration for SMF record 119 does not have TCPTERM subrecord specified 
IPDI52H5 Error: TCPIP - Stack Configuration for SMF record 119 does not have FTPCLIENT subrecord specified 
IPDI52H5 Error: TCPIP - Stack Configuration for SMF record 119 does not have TN3270CLIENT subrecord specified 
IPDI52I0 Checking MVS SMF Configuration 
IPDI52I9 MVS SMF configuration test completed 
Resolution:

1. One must properly define security for the SOLVE SSI userID. It is documented in DocOps at this address:

https://docops.ca.com/ca-netmaster-shared-content-library/12-2/en/install-or-upgrade-ca-netmaster-products/prepare-ibm-communications-server-tcp-ip-and-ftm-only#PrepareIBMCommunicationsServer(TCP/IPandFTMOnly)-TraceNetworkManagementInterface(nwmipOnly)

Workaround: in your SSIPARMS set PATRACENMI=NO until security can be defined correctly


2. The TCP/IP stack must be configured to write TYPE 119 records as documented at this address:

https://docops.ca.com/ca-netmaster-shared-content-library/12-2/en/install-or-upgrade-ca-netmaster-products/prepare-ibm-communications-server-tcp-ip-and-ftm-only#PrepareIBMCommunicationsServer(TCP/IPandFTMOnly)-VerifythatSMFRecordsAreBeingCreatedandProcessed(nwmipOnly)