smaccess.log fails to roll over intermittently.

Document ID : KB000044482
Last Modified Date : 14/02/2018
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Problem: 

smaccess.log fails to roll over intermittently.



The problem may be still observed even after the below fix is applied.

Policy Server 12.51 CR05:

74549           The smaccess.log and the smps.log files fail to roll over intermittently.

 

CA SiteMinder Policy Server 12.52 SP01 CR01:

117317      The smaccess.log and smps.log files fail to rollover intermittently.

 

Environment:  

Policy Server r12.51, r12.52 SP1

OS: All

Cause: 

The calculation of rollover has a defect still.

Resolution:

In r12.51, the fix will be included in CR09 (scheduled in 2016 Q4, as of 2016 June).

In r12.52 SP1, the fix is included in CR05.

 

Workaround:

(1) Stop the Policy Server

(2) Clear the value of LastRolloverTime parameter on registry. (Set it to zero.)

HKEY_LOCAL_MACHINE\SOFTWARE\Netegrity\SiteMinder\CurrentVersion\Reports\LastRolloverTime

 

(3) Start the Policy Server