SM 17.1 installer failed at auto-integrating with product(s) task while doing catalog upgrade

Document ID : KB000098390
Last Modified Date : 29/05/2018
Show Technical Document Details
Issue:
Upgrade failing at Integrating the products. Issue with Create Common Administrator in Unified Self-Service.  In install.log , it has the following errors :
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2018/05/17 11.00.21.989 DEBUG [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] Execution of integration task (com.ca.smsi.installui.integration.tasks.CreateCASMAdminUserInOSOP) is true
2018/05/17 11.00.21.990 DEBUG [DeployThread: Integrating the Product(s)] [AutoIntegrateTask] Executing auto-integration task : Class <com.ca.smsi.installui.integration.tasks.CreateCASMAdminUserInOSOP> . Integration isAllowed : true
2018/05/17 11.00.21.990 INFO  [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] Executing auto integrate task : task.auto_integration.CreateCASMUserInOSOP
2018/05/17 11.00.21.990 DEBUG [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] ======================= START CreateCASMUserInOSOP =======================
2018/05/17 11.00.21.990 DEBUG [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] Validating Integration endpoints for task: CreateCASMAdminUserInOSOP
2018/05/17 11.00.21.991 DEBUG [DeployThread: Integrating the Product(s)] [CommonUtil] Checking response from URL (http://localhost:8686)
2018/05/17 11.00.22.031 DEBUG [DeployThread: Integrating the Product(s)] [CommonUtil] Response : 401
2018/05/17 11.00.22.032 DEBUG [DeployThread: Integrating the Product(s)] [OSOPValidator] Unified Self-Service endpoint validation successful.
2018/05/17 11.00.22.032 INFO  [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] Creating CASMAdmin user in First Tenant of Unified Self-Service
2018/05/17 11.00.22.032 DEBUG [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] Unified Self-Service details : Server (localhost) Port(8686) AdminUser(SI_CAReqFul_P) AdminUserPwd(<PASSWORD>) Protocol(http)
2018/05/17 11.00.22.032 DEBUG [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] Unified Self-Service URLs details : REST (http://localhost:8686/rest) Session(http://localhost:8686/rest/session) osopUserURL (http://localhost:8686/rest/user)
2018/05/17 11.00.22.164 DEBUG [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] Login Successful. Response {"Object":{"sessionId":"F9F1CDC73AEEEBA43091DD5902F3CCB8","user":{"userId":107501,"firstName":"si_careqful_p","middleName":"","lastName":"","screenName":"si_careqful_p","emailAddress":"si_careqful_p5264@bcbst.com","companyId":10154,"languageCode":"en_US","phoneNumber":"","portraitId":0,"title":"","rank":1,"rankColor":"blue","interests":"","competencies":"","communities":"General Topics","notificationsFollowing":true,"notificationsRecommended":false,"notificationsLatest":false},"isSDMAvailable":true,"SDMProperties":{"label":"Request","instructions":"Create a new Incident","serviceDeskRestUrl":"http:\/\/WP001338:8050"},"sdmServerURL":"http:\/\/WP001338:8080\/","sdmServer":"WP001337","isCatalogAvailable":true,"CatalogProperties":{"catalogBaseUrl":"https:\/\/sctools.bcbst.com\/usm\/","defaultOfferingId":"10019","myAssetOfferingId":"","businessUnit":"","eemAppContext":"","showSDMTickets":"Y"}},"Result":{"HTTPStatus":200,"message":"Request processed successfully","message_key":"HTTP_SUCCESS_MESSAGE"}}
2018/05/17 11.00.22.171 DEBUG [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] Session ID: F9F1CDC73AEEEBA43091DD5902F3CCB8
2018/05/17 11.00.22.171 DEBUG [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] Response String: {"Object":{"sessionId":"F9F1CDC73AEEEBA43091DD5902F3CCB8","user":{"userId":107501,"firstName":"si_careqful_p","middleName":"","lastName":"","screenName":"si_careqful_p","emailAddress":"si_careqful_p5264@bcbst.com","companyId":10154,"languageCode":"en_US","phoneNumber":"","portraitId":0,"title":"","rank":1,"rankColor":"blue","interests":"","competencies":"","communities":"General Topics","notificationsFollowing":true,"notificationsRecommended":false,"notificationsLatest":false},"isSDMAvailable":true,"SDMProperties":{"label":"Request","instructions":"Create a new Incident","serviceDeskRestUrl":"http:\/\/WP001338:8050"},"sdmServerURL":"http:\/\/WP001338:8080\/","sdmServer":"WP001337","isCatalogAvailable":true,"CatalogProperties":{"catalogBaseUrl":"https:\/\/sctools.bcbst.com\/usm\/","defaultOfferingId":"10019","myAssetOfferingId":"","businessUnit":"","eemAppContext":"","showSDMTickets":"Y"}},"Result":{"HTTPStatus":200,"message":"Request processed successfully","message_key":"HTTP_SUCCESS_MESSAGE"}}
2018/05/17 11.00.22.171 INFO  [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] Checking in CASMAdmin user already exists in USS
2018/05/17 11.00.22.177 ERROR [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] Unable to check if CASMAdmin user exists. trying to create a new one.
2018/05/17 11.00.22.180 ERROR [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] Exception occoured during user creation
2018/05/17 11.00.22.180 ERROR [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] null.
2018/05/17 11.00.22.181 ERROR [DeployThread: Integrating the Product(s)] [CreateCASMAdminUserInOSOP] CASMUser Creation in first Tenant failed
2018/05/17 11.00.22.189 ERROR [DeployThread: Integrating the Product(s)] [AutoIntegrateTask] Error occured during intergration task : Creation of CASMAdmin user in Unified Self-Service failed.
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Environment:
install/upgrade catalog to 17.1 
Cause:
SM 17.1  installer insists on creating a new CASMAdmin for USS upgrade here which is causing the issue  with Catalog upgrade here .   
Resolution:
SM 17.1 forcefully does "auto-integration"  among all SM products based on the information in common table  al_cdb_configurationparameters  .   In the senario  we encountered here  it  forcefully attempted to create CASMAdmin user for USS so that to do auto-integration for USS with other products .   We  have to prevent SM 17.1 installer from doing  it so that it can bypass "auto-integration" task and move forward to finish  catalog install/upgrade  by doing the following :

1)  Run the SQL query “select * from al_cdb_configurationparameters where configKey ='osop_is_upgrade'”.

If its configvalue  is set to 1,  manually update  to set it as  0 

2) close previous SM 17.1 installer GUI ,  and re-invoke it to finish the upgrade