Slow performance, all WPs indicate 100% load

Document ID : KB000087499
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
U00003434 Server routine  'UCGENX_R/GENX' required '0' minutes and '41,335' seconds for processing.

Overall slowness of the Automation Engine (AE) and Usage of WPs at 100%.

Investigation

The screenshots below are from an AE version 11.2.1+hf.1.build.440.  The WPs are at 100%.
0EMb0000001QTz6.png

Checking the WP logs indicates that the routine "UCGENX_R/GENX" took a long time to process.
 
20160525/044555.978 - U00003434 Server routine  'UCGENX_R/GENX' required '0' minutes and '41,406' seconds for processing.
20160525/050112.820 - U00003434 Server routine  'UCGENX_R/GENX' required '0' minutes and '41,335' seconds for processing.
20160525/050151.641 - U00003434 Server routine  'UCGENX_R/GENX' required '0' minutes and '38,595' seconds for processing.
20160525/050304.300 - U00003434 Server routine  'UCGENX_R/GENX' required '0' minutes and '44,819' seconds for processing.
20160525/050349.563 - U00003434 Server routine  'UCGENX_R/GENX' required '0' minutes and '37,950' seconds for processing.
20160525/051547.142 - U00003434 Server routine  'UCGENX_R/GENX' required '0' minutes and '20,343' seconds for processing.
20160525/053058.012 - U00003434 Server routine  'UCGENX_R/GENX' required '0' minutes and '22,466' seconds for processing.
 
Environment:
OS Version: N/A
Cause:
Cause type:
Defect
Root Cause: Slow performance when tasks with a significantly high volume of object values are processed.
Resolution:
Update to a fix version listed below or a newer version if available, where performance of tasks has been improved when high volume of task values are being used.

Fix Status: Released

Fix Version(s):
Automation Engine 12.0.0 - Available
Automation Engine 11.2.2 – Available
Automation Engine 11.1.4 - Available
Additional Information:
Workaround :
N/A