SLO executes the task set in Action more than once if fulfilled

Document ID : KB000084635
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
N/A

Service Level Objective (SLO) fulfillment is met more than once if the following conditions are met:

Fulfillment criteria is set similar to this:

0EM0N000001hzW2.png

* In UC_CLIENT_SETTINGS, a maximum PROMPT_RESPONSETIME has been set.
* The monitored task contains a PRPT and this PRPT is not filled within the limit defined in UC_CLIENT_SETTINGS / PROMPT_RESPONSETIME


Investigation

The issue may occur in a similar scenario:


1 - PROMPT_RESPONSETIME is set to '1' in UC_CLIENT_SETTINGS.


0EM0N000001hzm0.png

2 - Start a task that contains a promptset.
3 - Don't fill in the promptset - wait until the prompt response time has lapsed.
4 - The script will be automatically canceled with "U00012104 PROMPT_RESPONSETIME of task '<TaskName>' (RunID '<RunID>') has been exceeded."



Results

Expected : SCRI.SEND.MAIL should be executed once.

Actual : SCRI.SEND.MAIL is executed twice.

 
20171215/115839.759 - U00012111 Script 'SCRI.LET.IT.TIMEOUT' (RunID '0001548023') terminated with CANCEL.
20171215/115839.812 - U00007000 'SCRI.SEND.MAIL' activated with RunID '0001549014'.
20171215/115839.856 - U00007000 'SCRI.SEND.MAIL' activated with RunID '0001549015'.

 
Cause:
Cause type:
Defect
Root Cause: Unable to reproduce in version 12.0.4 and above.
Resolution:
The issue does not happen in version 12.0.4 and above.

Fix Status: Released

Fix Version(s):
Component(s) : Automation Engine Server + Initial Data

Automation Engine 12.0.4 - Available
Additional Information:
Workaround :
N/A