SIB Services Node is not displayed in Investigator

Document ID : KB000019277
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

You are not able to see the SIB Service node in Investigator.

First check the following:

  1. The custom service is configured properly. Check the custom service classpath which contains the location of the JAR file.
  2. Service Integrated Bus (SIBus) is configured in IBM WebSphere Application Server.
  3. SIB Service should be enabled to start at WebSphere Application Server startup.

Solution:

Check the pmi-config.xml file and see how the SIB Service is configured with Module Name.

For example, if the module name is "StatGroup.SIBService"
Then configure the IntroscopeAgent.profile with

introscope.agent.pmi.enable.StatGroup.SIBService=true

The PMI module names specified in IntroscopeAgent.profile need to match what Websphere PMI uses to name the corresponding PMI data xmlwhen being queried. The newer 9.1.x/9.5.x agent and powerpack versions support using "." at the end of PMI module name specification in IntroscopeAgent.profile. This allows you to avoid appending the "Module" suffix to the PMI module name used in the query.

In some cases, you may need to include a dot for the SIB metric to show up. This is because Websphere tries to resolve a path where the SIB metric resides based on our agent profile setting. If it fails, it modifies the property and then tries various combinations to resolve the path. If all those fail, Introscope also fails and no SIB metric is seen. If one succeeds, the agent uses that one.

Since SIB changes in each version of WAS (6.0, 7.0, 8.0 and sometimes each subversion of those releases) there may be a need to try different settings of the property as per the examples below.

For example note the addition of the "." at the end of the property before the setting of true.
introscope.agent.pmi.enable.StatGroup.SIBService.=true

In this example, note where the "\." is located.
introscope.agent.pmi.enable.StatGroup\.SIBService=true

If after trying the above and you are still not seeing SIB metrics, contact CA Support.