Should a Datacom application be able to run using Datacom version 15.0 STEPLIB when the Datacom Multi-User (MUF) which is still at version 14.0?

Document ID : KB000013055
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

I have a Datacom Primary and Shadow Multi-User (MUF) configuration. Only one of the two MUFs have been upgraded at this time from Datacom version 14.0 to 15.0.

Some of my application JCL procedures have already been updated to use the Datacom version 15.0 libraries.

The applications which use the 14.0 libraries have no problem using either version 14.0 or 15.0 MUF.

But, the applications which use the 15.0 libraries terminate when attempt to use the 14.0 MUF.

They run fine when they execute in the 15.0 MUF but wait then fail with Datacom RC 68(01):  

DB00121I - UNAVAILABLE - muf1,muf2
DB00122I - ACCESS TYPE - LOCAL,XCF(xcfgrp)    TASKS=n
DB00123I - WAITING FOR MUF AVAILABILITY
DB00124W - REMAINING DELAY68 TIME -    2 MINUTES
DB00124W - REMAINING DELAY68 TIME -    1 MINUTES
DB00501E - OPEN ERROR - RETURN CODE 68 (001) CXX=           

Question:

Should a Datacom application be able to run using Datacom version 15.0 STEPLIB when the Datacom Multi-User (MUF) which is still at version 14.0? 

Environment:
z/OS
Answer:

No. Datacom applications must run at the same or lower level of Datacom software as the Datacom Multi-User (MUF). This applies to versions 15.0 or version 15.1 and 14.0.