Short runtime Jobs fail to trigger the completion of the PLOG report

Document ID : KB000084688
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
20161121/122852.363 - 24 U2000005 Job 'XXX with RunID '3909841' started.
20161121/122852.364 - 24 U2000003 Job 'XXX' started with RunID '3909841'.
20161121/122852.732 - 33 U2000009 Job 'XXX' with RunID '3909841' ended with return code '0'.

When the Agent gets a REP_GET message for a PLOG it first checks if the Job is still running. It delays the reply (REP_DATA) until the Job has ended or the Job writes into the PLOG. This makes it possible to see what the Job is doing while it is active.

If the Job is not active anymore the REP_GET message for a PLOG is answered immediately (normal transfer of a report like type REP).

In some cases a timing problem can occur if the runtime of the Job is very short. The REP_GET message for the PLOG has been received after the Job has ended but before it was removed from the Job table (JOB_DEL message).

Thefore the Agent delayed the PLOG reply until the Job has finished or someone writes into this file. But if the Job is already finished, the completion of the PLOG report is never triggered.

Normally the PLOG transfer starts directly after the Job execution.


 
Cause:
Cause type:
Defect
Root Cause: The Automation Engine sporadically generates invalid filenames for optional reports if the Agent has not sent the variable UC_EX_PATH_JOBREPORT in the EXSTART2 message, or that variable is empty.
Resolution:
Update to a fix version listed below or a newer verison if available.

Fix Status: Released

Fix Version(s):
Automation Engine 12.0.4 - Available
Additional Information:
Workaround :
Specify a directory for UC_EX_PATH_JOBREPORT in the ini file of the Agent.