Setup spins during upgrade to CA Service Management 17.1

Document ID : KB000100464
Last Modified Date : 07/06/2018
Show Technical Document Details
Issue:
When you launch the CA Service Management 17.1 setup.exe program,  it just keeps spinning.

 
Environment:
CA Service Management 17.1
All Supported Windows Operating Systems
Cause:

SETUP.EXE installer produces run time logs (that get copied to the installer logs folder later on) to c:\stdout.txt and c:\stdout.err

In checking the stdout.txt file, we see messages similar to: 

ERROR ProductXmlFileParserUtil.java    77 Caught Exception
java.io.FileNotFoundException: C:\Users\administrator\Desktop\DVD 1054\products\products.xml (The system cannot find the file specified)
	at java.io.FileInputStream.open0(Native Method)
	at java.io.FileInputStream.open(Unknown Source)
	at java.io.FileInputStream.<init>(Unknown Source)
	at com.ca.smsi.installui.utils.ProductXmlFileParserUtil.loadDocument(ProductXmlFileParserUtil.java:66)
	at com.ca.smsi.installui.utils.ProductXmlFileParserUtil.<init>(ProductXmlFileParserUtil.java:53)
	at com.ca.smsi.installui.wizard.CommonComponentLaunchPage.<init>(CommonComponentLaunchPage.java:101)
	at com.ca.smsi.installui.WizardMediator.<init>(WizardMediator.java:215)
	at com.ca.smsi.installui.InstallerUI.main(InstallerUI.java:210)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at com.zerog.lax.LAX.launch(DashoA8113)
	at com.zerog.lax.LAX.main(DashoA8113)
 
C:\stderr.txt file contains an exception error similar to:

Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
	at com.ca.smsi.installui.wizard.CommonComponentLaunchPage.actionPerformed(CommonComponentLaunchPage.java:397)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
Resolution:
The scenario described happens because the CA Service Management 17.1 ISO image was extracted to the server local hard drive, but the extracted folder name, "DVD 1054" in this case, has an embedded space(s) in its name.

To resolve the issue:

1.  Stop the CA Service Management 17.1 installer
2.  Rename the CA Service Management 17.1 extracted folder name to remove any embedded space(s) in its name.  For example, rename directory to "DVD_1054" instead of "DVD 054"
3.  Restart the CA Service Management 17.1 installer
Additional Information: