ServiceNow connection is validated but no Service Desk fields are available for selection in sdgtw

Document ID : KB000123441
Last Modified Date : 20/05/2019
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Issue:
In the sdgtw probe, a ServiceNow service desk application connection is created and the connection is successfully validated, but no fields are available from the configured ServiceNow service desk application for mapping in the Field Mapping table.  Any field mappings already defined contain a null value.
Environment:
UIM 8.51 or any supported release
sdgtw any version through 2.1T1
Cause:
The user configured in the connection profile was missing the personalize_dictionary role in ServiceNow.
Resolution:
The configured user in the ServiceNow connection profile minimally needs to have the following roles assigned in ServiceNow:

ITIL
personalize_dictionary
SOAP
Additional Information:
Important:
When using a "cloned" ServiceNow profile, save the profile before validating.
Close the sdgtw configuration window and re-open it.
Avoid using spaced in ServiceNow configuration profiles also.