Service Desk takes a long time to start due to "heavy logging" of SQL Queries

Document ID : KB000026858
Last Modified Date : 14/02/2018
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Issue: 

Service Desk takes a long time to start due to "heavy logging" of SQL queries.
In the stdlog this kind of message may be present:

sql_agent          6072 SIGNIFICANT  prov_base.c  717 
SQL Query has returned (275000) rows for (domsrvr/).  
SQL Statement (SELECT .., .., .., .. FROM <custom_table> ORDER BY .. )

Environment:  

CA Service Desk 12.x, 14.1

Windows, Linux e Unix

Cause: 

The problem could be due to MLIST and RLIST set to ON for the specific, often custom, table.

Workaround:

1. Check the definition of the appropriate object, defined in the .mod file. 

For 12.9 refer to:

‘CA Service Desk Manager Technical Reference Guide’, ‘5: Object Definition Syntax’, ‘OBJECT Statement’, ‘STANDARD_LISTS Optional Statement’

For 14.1 refer to ‘STANDARD_LISTS Optional Statement’ available at the link:

https://docops.ca.com/ca-service-management/14-1/en/reference/ca-service-desk-manager-reference-commands/technical-reference/standard_lists-optional-statement

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MLIST ON|OFF Indicates whether to produce a master list, which includes all objects, using one of the following values:

Value Description
ON Produces a master list (default if SORT_BY is specified)
OFF Does not produce a master list (default if SORT_BY is not specified or has no value defined)

RLIST ON|OFF Indicates whether to also produce a restricted list, which includes only the objects that meet the criteria in the WHERE clause, using one of the following values:

Value Description
ON Produces a restricted list (default if WHERE is specified)
OFF Does not produce a restricted list (default if WHERE is not specified or has no value defined.)

Note: RLISTs can speed up access and display but they use memory. They are usually used in select windows.
Important! MLIST OFF must be specified if you specify RLIST OFF.

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2. Set appropriately the MLIST and RLIST