Servers missing from Performance Center after integrating with Spectrum

Document ID : KB000032534
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue:

After integrating Performance Center and Spectrum some virtual servers are not discovered in Performance Center while others are. After turning on debug in Spectrum for Performance Center Integration and Performance Center Integration Synch the following message is seen in the Spectrum tomcat log (catalina.out or stdout.log)

Aug 11, 2014 8:40:10 AM (http-bio-8080-xxx-xx) (NetqosSyncLog) - (TRACE) - Device 0x3019219 is not active yet, added to postponed list for later processing

 

Environment: 

CAPC 2.3.X and up

Spectrum 9.3.x and up

 

Resolution:

In Spectrum the MODEL_STATE (0x1007c) must be set to 1 (Active). If it is not, it is added to the postponed list for later processing. To change the MODEL_STATE of the virtual server that was discovered by Virtual Host Manager (VHM) in Spectrum you should do the following:

1. Confirm the device is up and accessible 

 

If the device was discovered by virtual host manager: 

 

  • Change attribute EditModeMask (0x130cc) from a value of 244 to 0. This will give you the ability to delete the device
  • After deleting the device VHM polls the VCAIM and determines that there is a missing VM or possibly a new VM and repopulates it
  • The MODEL_STATE (0x1007c) should now be Active

 

2. Confirm the device is in the IP Domain collection after performing step #2. If it is not you can do the following:

 

3. Right click the IP Domain collection > Component Details > hit the "Update Global Collection Now" button. This should add the device in question to the IP Domain collection

 

 

4. You can either do a resynch of the Spectrum data source or let it synch on it's own.

 

The device in question should now be successfully pulled into Performance Center