Agent causing high CPU - threads got stuck

Document ID : KB000097082
Last Modified Date : 20/08/2018
Show Technical Document Details
Issue:
WebLogic servers got stuck using high CPU. Based on customer analysis this was caused by wily classes.

In the server log you noticed that some execute threads got stuck due to the java agent code, here is an example:

####<7.3.2018 11.14.02 EET> <[ACTIVE] ExecuteThread: '62' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1520414042403> <[STUCK] ExecuteThread: '66' for queue: 'weblogic.kernel.Default (self-tuning)' has been busy for "678" seconds working on the request "Workmanager: default, Version: 0, Scheduled=true, Started=true, Started time: 678498 ms 

POST
...
]", which is more than the configured time (StuckThreadMaxTime) of "600" seconds. Stack trace: 
java.util.HashMap.getEntry(HashMap.java:465) 
java.util.HashMap.containsKey(HashMap.java:449) 
java.util.HashSet.contains(HashSet.java:201) 

com.wily.introscope.agent.sqlagent.StatementNormalizer.normalizeSQL(StatementNormalizer.java:813) 
com.wily.introscope.agent.sqlagent.StatementToSQLMappingTracer.normalizeForMetricName(StatementToSQLMappingTracer.java:408) 
com.wily.introscope.agent.sqlagent.StatementToSQLMappingTracer.ITracer_finishTrace(StatementToSQLMappingTracer.java:282) 
com.wily.introscope.agent.trace.InvocationData.IMethodTracer_finishTrace(InvocationData.java:1504) 
Environment:
Valid for APM 10.5.2 and 10.7.0 only
Cause:
 This problem is related to defect DE352576 due to corrupted hashmap in SQLAgent.
Resolution:
You have 2 options:

a) Upgrade to 10.7 SP1

b) Apply 10.5.2 hotfix # 36  - to contact a copy of this hotfix contact CA Support.