Selected Index attribute in select dropdown field in 17.1

Document ID : KB000124910
Last Modified Date : 17/01/2019
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Issue:
The "Selected Index" attribute in select dropdown element in  the form no longer works as expected  once catalog is upgraded from 14.1 to 17.1  and applied 17.1 rollup2 patch 
Environment:
ITSM service catalog 17.1 with rollup2 patch applied , and the versions afterwards . 
Cause:
Normally the users  do  not  purposely specify "Page Size" attribute for select dropdown  .      With default value  ( i.e. no any value specified in "Page Size" ) ,   on 14.1 ,  when form is loaded ,  it loads ALL the data to pre-populate the select dropdown list at the very beginning  .  Therefore ,  whatever value specified in "Selected Index"    will work  as soon as it is in the dropdown list. 

However ,  with 17.1  ( specifically  after  17.1 rollup2 patch and the versions afterwards  ) ,   our dev  made continuous  effort to   improve/enhance  the overall performance relating to the forms .     With  default value in "Page Size" attribute  ( i.e.  no any value explicitly  specified in "Page Size" )  ,  it loads/pre-populates  only 7 entries in the list first at the time that  the form is just loaded at the very beginning  .     if "Selected Index" attribute value is greater than 7 and the "Page Size" attribute value is empty ,   it will not be work in 17.1  because the "Selected Index" value is less than the default "Page Size" value 7 here .      

 
Resolution:
From  17.1 rollup2 and the versions afterwards  ,   when specifying "Selected Index" value for select dropdown ,  it has to combine with specifying  "Page Size" value .   For example ,   if you want to specify "Selected Index" value as 72 ,   you have to also specify "Page Size" value  and  set  "Page Size" value  be greater than or equal to "Selected Index" value 72 here .