Seeing HTTP Plugin Load Failure and "Communication 500 Errors."

Document ID : KB000077045
Last Modified Date : 10/04/2018
Show Technical Document Details
Question:
What should I do in the following situation?

After APM CE (CEM) configuration changes, a TIM monitor sync fails with a "Monitor Configuration Status" of "Communication Error 500" showing plugin load failure.

Also, the TIM becomes disabled:

User-added image

 Other information:

"Domain Configuration Status" shows as "Normal" 

"Monitor Configuration Status" shows "Communication Error 500"

Clicking on the "Communication Error 500" link or checking the MOM log may show a plugin load error e.g.


TIM Error:

Monitor Configuration Status: Communication Error 500

500 Error cannot load plugin "53" while it is enabled

 

MOM Error:

INFO | jvm 7 |<Date & Time> [ERROR] [Thread-XX] [Manager.com.timestock.tess.services.tim.TimIo] cannot send plugin to monitor id=nnnnnnnnnnn: Communication Error 500: 500 Error 

INFO | jvm 7 | <Date & Time> | cannot load plugin "53" while it is enabled
 
Environment:
All Supported APM Releases with TIM
Answer:
To resolve the problem, do the following if the original plugin jar files are still available for reload:

Delete the plugins from the CEM UI -> Setup -> Plug-ins page.
Restart the MOM, the EM running the TIM Collection Service, and the TIM.
Reload the plugins using the CEM UI -> Setup -> Plug-ins page and "Synchronize All Monitors."
If the original plugin jar files are not still available for reload, then create a support case for further assistance.