Security adapter installation with Seible IP15

Document ID : KB000111407
Last Modified Date : 29/08/2018
Show Technical Document Details
Question:
We're running an Agent for Siebel IP7, and upgraded to Siebel IP15.
For that, we'd like to get the download link for the ERP Agent for Siebel on Siebel IP15, and the
documentation related to it as it needs to be configured as 5.x Agent.
 
Answer:
At first glance, with Siebel IP15 you can only use the ERP Agent 12.51
on SunOS and RedHat. Here are the details for download, support matrix
and documentation you requested.

  CA Single Sign-On Agent R12.51 for ERP Systems (Oracle PeopleSoft, Siebel, SAP) Platform Support Matrix

  | Siebel version  | Solaris 10 64bit | RedHat 6 64bit |
  |-----------------+------------------+----------------|
  | Siebel Server   | Yes              | Yes            |
  | Innovation Pack |                  |                |
  | 2015            |                  |                |

  https://support.ca.com/us/product-content/recommended-reading/technical-document-index/ca-siteminder-informational-documentation-index.html

You'll find the binaries here :

   Go to : https://support.ca.com/us/download-center.html?r=1

   and search for : "CA Single Sign-On Agent for Siebel MULTI-PLATFORM"

  This one has the following binaries :

    CA SINGLE SIGN-ON AGENT R12.51 FOR SIEBEL FOR SOLARIS-32- ESD ONLY
    GEN05101422E.zip

    CA SINGLE SIGN-ON AGENT R12.51 FOR SIEBEL FOR LINUX-32- ESD ONLY
    GEN05101503E.zip

You'll find the related documentation here :

  CA SSO Agent for Siebel
  https://docops.ca.com/bookshelves/ca-sso-agent-for-siebel

  which gives you the link to "CA SSO Agent for Siebel Guide" and "CA
  SSO Agent for Siebel Release Notes".

The version 12.51 can also work in 5x mode, as stated by the Release 
notes : 

Agent for Siebel Release Notes r12.51 

Chapter 3: New Features 

Agent Communication Model 
This product now communicates with the Policy Server using the trusted host 
communication model. 

CA_SSO_Agent_for_Siebel_Release_ENU.pdf 

this means that now the ERP Agent for Siebel can work also with the 
trusted host model (5x). On previous version, it can't. 

Configuring in 4x version is supported with IP15. 

You should not use these libraries on the Policy Server : 

libnpssessionlinker.so - Package: NPSSessionLinker V5.60.0423.557 
libnpssessionlinker.so - Component: NPSSessionLinker Configuration Active Response V5.60.0423.557 (Dec 15 2011 12:17:11) 

but the ones that are shipped with the Session Linker 12.52