Search feature on the portal is not functional

Document ID : KB000125243
Last Modified Date : 24/01/2019
Show Technical Document Details
Question:
When we try to search for a user or resource in the Identity portal it doesn't go through and on close of the search it shows a blank page. But when the same feature is made use of using the advanced search it works good.
Answer:

"HF-DE395608.zip" sent to client. 

This HF fixes the problem of the search in Certification Campaigns screen that fails when one of the campaign objects does not have any displayable attributes (in the customer's use case it seems to be that ROLE objects has no displayable attributes). The campaign template must have the user name attribute (or any other USER attribute that contains the user's name) for the search to find users by their names, this is by design. The User Display attribute also points to the same user name attribute, the same value will appear twice in the tasks table. If you do not want the user name to appear twice in the tasks table, it is possible to mark the user name attribute in the campaign template as "Available for display" but not as "Default display". This will make sure that unless the logged in user deliberately chose to add the user name attribute to the table, by default, this attribute will not be displayed.

If needed please open a separate IDEA on the IMAG community for this request.

KB000044090, "How to submit a product enhancement request for Identity Manager and other CA Security applications"