SDM PAM Integration stopped working SDM cannot call or process anything from PAM

Document ID : KB000111431
Last Modified Date : 16/08/2018
Show Technical Document Details
Issue:
SDM/PAM integration is not working. SDM cannot call anything from PAM and all processes that should be triggered from SDM to PAM are not working.

If a macro is created from SDM that call PAM (Administration > Events and macros > macros > Create new> Select type: IT PAM > Click on "CA IT PAM Definition" > SDM returns a Delayed Server Response.

PDM_RPC process is up and running based on pdm_status and stdlog. It does not crash or something similar.
RAM memory does not increase and is stable for the javaw.exe process of pdm_rpc
No error found in the logs (stdlog and jstdlog in DEBUG level).
PAM is working OK.
Able to log into PAM from SDM server using URL's set in Options Manager > CA IT PAM Workflow. Using user/password set in Options Manager > CA IT PAM Workflow



 
Environment:
Service Desk Manager 14.1 Cum 2 and later
Process Automation 4.2 SP2 and later
Cause:
pdm_rpc is unable to initialize the EEM SafeConfigurator
Resolution:
A workaround for this issue is the following:

1. Log into SDM as an administrator (ex: ServiceDesk)
2. Administration > Options Manager > CA IT PAM Workflow > Uninstall CAEXTWF_EEM_HOSTNAME
3. Restart SDM Services for the changes to take effect.
4. Delete cache from browser > Log into SDM and try to create an IT PAM type macro and verify events are being called from SDM.

More details about the CAEXTWF_EEM_HOSTNAME option in the additional information link.
Additional Information:

Install the CA Process Automation Workflow Options
https://docops.ca.com/ca-service-management/14-1/en/troubleshooting/troubleshooting-ca-service-management/integrate-ca-service-desk-manager-with-common-components-manually/integrate-ca-service-desk-manager-with-ca-process-automation-manually#IntegrateCAServiceDeskManagerwithCAProcessAutomationManually-InstalltheCAProcessAutomationWorkflowOptions