SAP Agent cuts of the Message ID

Document ID : KB000084336
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
N/A

After an update to Automation Engine 10 or higher you may experience a different behavior when using an SAP Agent.

The Message ID will get cut off if XBP 2.0 is set in the Connection object.

With XBP 2.0 in the Connection object the JOB REPORT looks like this:

 
2017-11-08 14:48:32 00 516 Job started 
2017-11-08 14:48:32 00 550 Step 1 started (Program RSM51000, Variant , User XXX) 
2017-11-08 14:48:32 00 517 Job finished 
2017-11-08 14:48:32 000 ---------------------------------------------------------------------------------------------------- 
2017-11-08 14:48:32 000 Step 001 Program RSM51000 Spoolnumber 0000272626 
2017-11-08 14:48:32 000 Step has no selection screen. 


 
With XBP 3.0 setting in the Connection object is works as expected:

2017-11-08 14:46:53 00 S516 Job started 
2017-11-08 14:46:53 00 S550 Step 1 started (Program RSM51000, Variante , Benutzername XXX) 
2017-11-08 14:46:53 00 S517 Job finished
2017-11-08 14:46:55 000 ---------------------------------------------------------------------------------------------------- 
2017-11-08 14:46:55 000 Step 001 Program RSM51000 Spoolnummer 0000272625 
2017-11-08 14:46:55 000 Step has no selection screen. 
Cause:
Cause type:
Configuration
Root Cause: This problem occurs when XBP 2.0 is used in the connection Object for SAP.
Resolution:
Use Automation Engine Version 10 or higher and change the XBP Version to 3.0 in the SAP Connection Object of your Automation Engine.

Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
N/A