SAM upgrade. In the section titled: Confirm the Configuration of the existing SQL Server Database, it wants me to confirm that SQL Server 2012 native client is installed. We are using SQL Server 2008. Should I install the SQL Server 2012 native client?

Document ID : KB000045983
Last Modified Date : 14/02/2018
Show Technical Document Details

Question: 

I'm upgrading my SAM 4.0.1 installation to 4.0.2.  Under the section, Confirm the Configuration of the existing SQL Server Database, it wants me to confirm that SQL Server 2012 Native Client is installed.  Should I install the SQL Server 2012 Native Client if we are using SQL Server 2008? 

 

Environment: 

CA Software Asset Manager 4.x releases

 

Answer: 

Yes, download and install the SQL Server 2012 native client even if you are using SQL Server 2008 as your database management system.

SQL Server 2012 native client is backward compatible with SQL Server 2008. 

 

Additional Information: 

See this link for more detailed information on the SQL Server 2012 native client:  https://msdn.microsoft.com/en-us/library/jj730314(v=sql.1).aspx