running DC Cobol from multiple releases

Document ID : KB000105676
Last Modified Date : 06/07/2018
Show Technical Document Details
Question:
If we run mostly the latest LE Cobol but also have some older cobol programs (Cobol II for example), does CDMSLIB need both the latest SCEERUN and the older runtime loadlib?
Answer:
No.  The latest SCEERUN will support the latest LE and older Cobol programs.

It will not hurt if the SCREEUN is first and the older Cobol runtime lib is concatenated after it, but the older runtime lib is not necessary.
Additional Information:
https://docops.ca.com/ca-idms-ref/19/en/dml-reference-for-cobol/considerations-for-ibm-language-environment