Running any CA Service Desk Manager (CA SDM) command results in a Visual C++ error "Debug Assertion Failed"

Document ID : KB000004061
Last Modified Date : 14/02/2018
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Issue:

If you run any CA Service Desk command, such as pdm_configure, pdm_status etc., the following error appears:

error.jpg

Environment:
CA Service Desk Manager 12.x, 14.x and 17.0All Supported Windows Operating Systems
Cause:

Improper file format of the NX_ROOT\NX.ENV file

Resolution:

The reason why this error appears is because the NX_ROOT\NX.ENV was edited manually and was not saved in the right encoding.

If the file is saved in "UTF-8", "Unicode" or "Unicode big endian" encoding, the Visual C++ error will appear. 

The supported and correct encoding format for the NX.ENV file is "ANSI". 

ansi.jpg

 

Once the NX_ROOT\NX.ENV file has been saved with the proper encoding and the CA SDM services recycled, the error will no longer occur when attempting to run CA SDM commands.

 

Additional Information:

TEC612988 - Best Practice when doing Changes to NX.ENV: using the 'pdm_options_mgr' command