'Run Command Line(SSH)' action hangs on agent indefinitely.

Document ID : KB000007028
Last Modified Date : 14/02/2018
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Issue:

When attempting to run the 'Run Command Line(SSH)' action specifically, it will hang at or around 75% indefinitely until the run is cancelled.

Environment:
Linux/Unix only.
Cause:

Typically the cause is going to be due to the console input being disabled for the wrapper service that the agent utilizes.   If you check /path/to/agent/logs/wrapper.log -- you should see something similar to:

 

WARNING - System.in has been disabled by the wrapper.disable_console_input property.  Calls will block indefinitely.

 

 

Resolution:

This property by default is set to FALSE for the wrapper configuration, however in some circumstances the environment can alter this.  

You will likely find that both Kerberos and GSSAPI authentication are enabled in sshd_config, which changes the boolean value of this property system wide, eg:

/etc/ssh/sshd_config:

# Kerberos options
KerberosAuthentication yes

GSSAPIAuthentication yes
GSSAPICleanupCredentials no
GSSAPIKeyExchange yes

------------------------------

 

There are two options here, one would likely be out of the question, and that is disabling Kerberos from testing thus far.  The other, far easier option is going to be editing:

 

/path/to/agent/conf/wrapper.conf:

add the line:

wrapper.disable_console_input=FALSE

--

 

Restart the deployer, and then run the action again and it should no longer hang.