RTM_Inventory models taking hours to activate and causing Global Collection Searches to not working

Document ID : KB000006690
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

After upgrading to Spectrum 10.2.0 we noticed our Global Collections are not getting updated, and when they do it takes more than a day before the updates start to run.  

Cause:

Enabling the Model Activation debug, and Global Collection Search debug, in the $SPECROOT/SS/.vnmrc file allowed us to see that model activation for RTM_TestHosts are taking a very long time to complete. This is holding up the Global Collection updates.

 

To enable the debugs:

1. Edit the $SPECROOT/SS/.vnmrc file

2. set wait_active=yes

3. set spm_wait_active=yes

4. add mdlact_debug=true

5. add real_time_search_debug=true

6. restart the SpectroSERVER

Spectrum reads the .vnmrc file at startup, therefore the SpectroSERVER must be stopped and restarted before the changes take affect. The debug outputs are written to the $SPECROOT/SS/VNM.OUT file. 

If you find the RTM_TestHosts are taking thousands of seconds to activate, you will benefit from the Spectrum_10.02.00.D171 patch.

Resolution:

Spectrum_10.02.00.D171 addresses a design issue, where we were activating each RTM_TestHost one at a time. The change provided by the patch takes advantage of the 50 multi-request threads, so now we activate the RTM_TestHosts 50 at a time, which significantly speeds up model activation for these models.