RSM: How can I tell which edition of Salesforce.com I have?

Document ID : KB000004174
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

NOTE: CA Agile Central Support Manager and CA Agile Central IBM ClearQuest Integration will no longer be enhanced or fixed and technical support will be discontinued effective September 30, 2017. Learn more here.

After successfully completing the installation and configuration steps, the RSM integration will not make a successful connection to Rally.

Environment:
Our Salesforce.com integrations will only work with Developer, Enterprise, and Unlimited editions of Salesforce. This KB quickly shows you how to tell which edition of Salesforce.com you have.
Cause:

The Professional Edition of Salesforce does not have access to the API, which is needed to run the RSM Integration.  If you install RSM using a Professional Edition, you'll notice the Rally Defect Fields page will not load.  Running Firebug on this page will show you the following error:

0EMa00000009Z5X.png

Resolution:

1. Login to Salesforce.com
2. Click "Setup" from the top right portion of your page
3. In the sidebar, click Administration Setup

0EMa00000009YSv.png

4.  The edition will be in the header of this page.  Here are some examples:

User-added image

User-added image

Note: RSM works with a Developer, Enterprise, or Unlimited edition of Salesforce.com.  RSM will not work with the Professional edition.