Robot not deployed correctly to some Linux x64 systems, including SUSE12SP2 and Ubuntu 16

Document ID : KB000008281
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

After deploying a robot to Linux systems including Ubuntu 16 or SUSE12SP2, you may be unable to distribute probes to the robot.  Attempting to distribute robot_update results in a "no sections found which can be installed" error.

Environment:
Ubuntu 16SUSE12SP2note: These represent the systems we have currently identified. CentOS, RHEL, and other supported Linux installations do not appear to be affected, but if the symptoms described in this article match the symptoms you are seeing in your environment, please try the same steps.
Cause:

This is caused by a defect in robot 7.91. 

 

Resolution:

1. download the new version of nimldr792.tar.Z and install_LINUX_23_64.zip from this article. (This package installs robot 7.92GA.)

2. On the Linux box enter these commands to kill and remove the current robot: 

killall nimbus 

rm -rf /opt/nimsoft/ 

3. use the new nimldr and install_LINUX_23_64.zip to reinstall the robot. When nimldr asks "Do we have a copy of the installation file locally?" say yes, and provide the path to this install_LINUX_23_64.zip file. 

This will install the robot correctly and you will now be able to upgrade it and/or deploy probes successfully.

 

nimldr792.tar.Z

install_LINUX_23_64.zip

 

 

Additional Information:

This issue will be resolved with the next GA robot installer release which will be released with UIM 9.0.

File Attachments:
TEC1865635.zip