Restman Error during API Portal Tenant Enrollment due to missing Portal API Key Sync Encapsulated Assertion

Document ID : KB000098743
Last Modified Date : 30/05/2018
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Issue:
The following restman error occurs when attempting to enroll a tenant gateway to an existing API Portal 4.X environment:
 
<l7:Mapping action="NewOrExisting" errorType="TargetNotFound" srcId="f6b0867f9dd395f4d60fd722248300d9" type="ENCAPSULATED_ASSERTION"> 
<l7:Properties> 
<l7:Property key="ErrorMessage"> 
<l7:StringValue>Could not locate entity: Fail on new specified and could not locate existing target. Source Entity: EntityHeader. Name=Portal API Key Sync, id=f6b0867f9dd395f4d60fd722248300d9, description=null, type = ENCAPSULATED_ASSERTION</l7:StringValue> 
</l7:Property> 
<l7:Property key="FailOnNew"> 
<l7:BooleanValue>true</l7:BooleanValue> 
</l7:Property> 
<l7:Property key="MapBy"> 
<l7:StringValue>name</l7:StringValue> 
</l7:Property> 
</l7:Properties> 
</l7:Mapping>

 
Environment:
CA API Gateway 9.2 or 9.3
CA API Developer Portal 4.X
Cause:
One of the prerequisites to Enroll a CA API Gateway tenant is a valid OTK installation. As noted in the Install the OAuth Solution Kit instructions the required OTK components to integrate with the CA API Developer Portal are the Internal, Portal and Shared Portal Resources solution kit components. 
Resolution:

Reinstall the OAuth Solution Kit per the Install the OAuth Solution Kit instructions. Ensure the More Installation Options for CA API Developer Portal are selected:

'Integrate with the CA API Developer Portal
Select the The Internal, Portal and Shared Portal Resources solution kit components.'

Additional Information: