Rest API error in app log while working in PPM New UI

Document ID : KB000124206
Last Modified Date : 16/01/2019
Show Technical Document Details
Issue:
"PPM_REST_API Error while loading attachments" displayed in app-ca log when Users access Timesheets from New UI

Steps to Reproduce:
  1. Login to the NSA of a PPM instance.
  2. Click on the Server and go to the Documents and Search tab.
  3. Verify that the Index directory and the Filestore directory (if the files are not stored in DB) are valid.
  4. If the Index and Filestore directories are not valid, then please correct the same.
  5. Logout from NSA and login to CA PPM as an admin user. Any user having access to New UI and multiple users timesheet will do.
  6. Go to New User Experience as the same user. Projects page will be the landing page.
  7. Click to go to the Timesheets tab in the New User Experience.
  8. Click on the Resource Finder icon (icon shows a resource within a binocular). The icon shows "Select resource to enter time" on hovering.
  9. A list of resources gets displayed based on the access of the logged in user.
  10. Make sure that 2 or more resources from that list are not having any Avatar for their accounts and display the initials.
  11. Check the app-ca.log for that server immediately.
Expected Result: Application log should not show any errors as there is no issues in the PPM front end.
Actual Result: Error messages, as shown below, are populated for all the Resources who did not have Avatars. This could be verifies by matching the Resource IDs mentioned in the logs with the Internal ID (5 million number) for the Resources in PPM.

ERROR 2019-01-07 06:50:20,771 [http-nio-80-exec-151] ppm.rest (clarity:admin:5617041__3577621F-8E88-488C-B7C5-74DFC9886477:PPM_REST_API) Error while loading attachments. attURL was null. Resource id = 5006025
ERROR 2019-01-07 06:50:20,802 [http-nio-80-exec-151] ppm.rest (clarity:admin:5617041__3577621F-8E88-488C-B7C5-74DFC9886477:PPM_REST_API) Error while loading attachments. attURL was null. Resource id = 5006060
ERROR 2019-01-07 06:50:20,834 [http-nio-80-exec-151] ppm.rest (clarity:admin:5617041__3577621F-8E88-488C-B7C5-74DFC9886477:PPM_REST_API) Error while loading attachments. attURL was null. Resource id = 5006036
ERROR 2019-01-07 06:51:06,790 [http-nio-80-exec-149] ppm.rest (clarity:admin:5617041__3577621F-8E88-488C-B7C5-74DFC9886477:PPM_REST_API) Error while loading attachments. attURL was null. Resource id = 5006025
ERROR 2019-01-07 06:51:06,821 [http-nio-80-exec-149] ppm.rest (clarity:admin:5617041__3577621F-8E88-488C-B7C5-74DFC9886477:PPM_REST_API) Error while loading attachments. attURL was null. Resource id = 5006060
 
Environment:
CA PPM 15.4, 15.5, 15.5.1
Cause:
Due to defect DE46342.
Resolution:
The defect has been fixed in CA PPM 15.6. 
Additional Information:
The issues happens when the list has one or more resources without a Avatar for their accounts. Login to PPM as anyone of those resources and add an Avatar for that user. Try to replicate by problem and the line corresponding to that resource, who just added an avatar, will not be there anymore in the app-ca.log. This could be verified through the Resource ID that is displayed in the error message.