Requests via web services gets incorrect BU

Document ID : KB000112085
Last Modified Date : 24/08/2018
Show Technical Document Details
Issue:
Created a Service Request for CA Service Catalog via web service. 
The web service user is also member of the customer BU. 
The created request contains an INcorrect BU. 
It contains the Root-Bu in stead of the BU, set in the web services.
Environment:
Windows 2012, sql 2014
SDM 14.1 CUM5
SLCM 14.1 CUM5
Cause:
Defect DE43606 has been created for this. To be worked on by our Engineering Team.
Depending on the results of the analysis, the solution for this is possibly to be expected as a patch or fix or a future release.
In other words, there is no permanent solution at this time.
Resolution:
N/A
Additional Information:
CA Product impacted
=====================
CA Service Catalog(SC)

Versions/Release and any patches
================================
CA SC R14.1.05

OS/Environment
==============
Windows 2012, sql 2014
SDM 14.1 CUM5
SLCM 14.1 CUM5

Description
===========
Created a Service Request for CA Service Catalog via web service. 
The web service user is also member of the customer BU. 
The created request contains an INcorrect BU. 
It contains the Root-Bu in stead of the BU, set in the web services.

Work around
===========
N/A

Analysis:
=========
1 In the SC-UI admin/users, create a new user bu1cat set for BU=non-root-bu, Role=Administrator. 
2 In SC-UI Home/Requests, create a new/dummy request. Any offering will do.
3a In SOAPUI, login with spadmin.
3b In SOAPUI, Set the property 'domain' in the web services method: 
<requestData xsi:type="xsd:string">name:6-TextAreaNewLine!req_by_user_id:spadmin!req_for_user_id:bu1cat!domain:non-root-bu</requestData> 
The newly created request (by web services) shows the correct domain/business unit.
>>> The issue for this case:
4 In SC/admin/users, change the Role for into 'Request Manager' (same BU).
<requestData xsi:type="xsd:string">name:6-TextAreaNewLine!req_by_user_id:spadmin!req_for_user_id:bu1cat!domain:non-root-bu</requestData> 
And then the request get created with the ROOT-BU.
Which should have been set to 'non-root-bu' as written in the web services.