Reports are not running with connection failure message

Document ID : KB000112474
Last Modified Date : 21/09/2018
Show Technical Document Details
Issue:
Customer is not able to run the reports in CABI. They are failing from CA Reports and custom reports. He gets a kind of message:

2018-08-22 14:24:34
com.businessobjects.report.web.shared.WebReportingException: The viewer could not process an event. Failed to open the connection.
<Report Name> [] ---- Error code:0 [CRWEB00000119]
Environment:
CA Service Desk Manager 14.1
Cause:
The ODBC Data Access Service were corrupted
Resolution:
Activities to ensure that all the environment is correctly configured:

. we check the odbc configuration in the CABI Designer. The test the odbc connections from Service desk side 32bit and CABI side 64bit connections and all were failed 
. Checked the User Preferences in the BI Launch PAD for the Cabi user that is trying to run the Report,  and set the locale to English 
. Checked the CCM processes and all those were up and running. 
. Checked the ODBC Agent and Data Access Services to ensure that they are up and running, however the ODBC Data Access was corrupted 

   - To solve it, customer manually killed the oasoa.exe process in the Task Manager in Service Desk Serve 
      Went in the %NX_ROOT\add-ons\tracing and deleted the all files from this folder. 

. Restarted the ODBC Data Access and ODBC Agent services 
. Restarted the Tomcat and SIA in CABI Server 
. tested the ODBC from Service Desk Server side 32bit and CABI Server side 64bit connections and all were OK now 
. The Reports ran successfully 
Additional Information:
CA Service Desk Manager Known Reporting Issues