Reporter is not connected to a database .

Document ID : KB000022069
Last Modified Date : 10/07/2018
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Issue:

The following error occurs while trying to open the DSM Reporter on a remote machine:

The DSM Reporter is not connected to a database and a DSM domain.


Domain Connect: Error opening domain database (%s/%s/%s) Db->Connect returned  %li
Connect to Database %s with username %s failed
cAmo: Domain->Connect failed
Data Manager - Unable to connect using manager name only - DB was not
initialized

Retry connection

Environment:
CA Client Automation - All Versions
Cause:
Newer versions of the standalone SQL Native Client Redistributable Tools do not include OSQL.EXE which is required for DSM Reporter to work properly.
Resolution:
The error occurs when the remote machine does not have a complete / updated SQL Client Tools installation which includes OSQL.EXE and required supporting files.

Since newer versions of the standalone SQL Native Client Redistributable Tools do not include OSQL.EXE, this cannot be used as an install media to meet the DSM Reporter requirements. To ensure the required item is installed on your system, please make sure to install Client Tools from a full Microsoft SQL Server installation media, selecting the following components in the 'Feature Selection' screen of the Microsoft SQL Server Setup:

1. Client Tools Connectivity
2. Client Tools Backwards Compatibility
3. Documentation Components*
4. Management Tools – Basic

*Optional item

Alternatively, you can try the following to bypass the error, but this is not recommended and may or may not be sufficient for Reporter to function:

From a computer with full SQL Server installation, copy the following files to the machine where DSM Reporter is being installed**.
    ...\Microsoft SQL Server\110\Tools\Binn\OSQL.EXE
    ...\Microsoft SQL Server\110\Tools\Binn\Resources\1033\osql.rll

**Paths may differ with SQL Server version.

NOTE: In general, the SQL version installed in this case should match the version used by the Domain or Enterprise Manager for best compatibility.
Additional Information:
DSM Reporter Grayed Out in DSM Explorer of CA Client Automation
https://comm.support.ca.com/kb/dsm-reporter-grayed-out-in-ca-client-automation/KB000105206