Report returns with No Data Available message

Document ID : KB000023392
Last Modified Date : 14/02/2018
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Problem:

When Running a report on eHealth against an element the report will show "No data available."

Environment:
eHealth 6.3.x
All supported platforms

Cause:

eHealth is not successfully polling the elements in question, therefore not collecting any data on said elements

Resolution:

Verify whether eHealth is polling a specific element.

  1. From the eHealth console select:  Reports -> Run -> Trend Reports
  2. Select the element in question
  3. Select the appropriate technology type
  4. Click Browse and select the element which is showing "No Data Available" in the report
  5. Click Browse and select the following variables:  Good Polls, Bad Polls, Missed Polls
  6. Select the appropriate time range
  7. Click Apply

This report will show whether eHealth is successfully polling the element.

Check the $NH_HOME/log/pollerStatus/messages.stats.log to see what polling errors are occurring.