Remote Publish Service not running - Domain Error

Document ID : KB000094204
Last Modified Date : 04/05/2018
Show Technical Document Details
Issue:
Issue Description:
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The Remote Engine Config Editor has been edited to point to the correct repository with "Email Support" disabled but AD Domain mentioned as seen in the screen shot below. The configuration is saved. When we click on the verify button we get the following error message.

User-added image
When we try to start the service from the "Status" tab, nothing is displayed. The service is still in the stopped state. See below.

User-added image
Environment:
Test Data Manager
Tool: Remote Engine Config Editor
Cause:
The cause can be determined from the log files. The steps are given below.
Resolution:
To debug this issue, please follow these steps:

1. Check if the information entered in the Config Editor is correct. This can be launched from the default location
    C:\Grid-Tools\RemotePublish\RemotePublish_ConfigEditor. 
2. Check the log file to find further details. The default location for that is C:\Grid-Tools\RemotePublish\logs
     The log files will show the following.
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2018-05-03 15:12:27,640 [4] ERROR DMBatch.DMBatch - License has AD disabled but domain 'Domain' is specified in configuration. License and domain configuration should be in sync

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Resolution:
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The license that has been provided is clearly without AD, but the Domain is mentioned in the Config Editor which is incorrect. Please delete the Domain details from the config Editor and click on the save button.
Now, when you start the service from the status tab, it should start without any errors.

 
Additional Information:
If you experience any issues, please open a support case on support.ca.com