VSE service will not start - java.lang.InternalError: WAL corrupted

Document ID : KB000076446
Last Modified Date : 27/09/2018
Show Technical Document Details
Issue:
Getting issues when starting the VSE.
This is the exception we are seeing during startup.

java.lang.InternalError: WAL corrupted 
        at org.mapdb.StoreWAL.replayWALInstructionFiles(StoreWAL.java:1044)
        at org.mapdb.StoreWAL.replayWAL(StoreWAL.java:999)
        at org.mapdb.StoreWAL.initOpen(StoreWAL.java:192)
        at org.mapdb.StoreDirect.init(StoreDirect.java:141)
        at org.mapdb.DBMaker$Maker.makeEngine(DBMaker.java:1504)
        at org.mapdb.DBMaker$Maker.make(DBMaker.java:1284) 
        at com.ca.devtest.util.collections.FileBackedMap.openDB(FileBackedMap.java:553)
        at com.ca.devtest.util.collections.FileBackedMap.dbWasReopenedFromClosed(FileBackedMap.java:537)
        at com.ca.devtest.util.collections.FileBackedMap.ensureMapAndDb(FileBackedMap.java:530)
        at com.ca.devtest.util.collections.FileBackedMap.(FileBackedMap.java:208)
        at com.ca.devtest.util.collections.FileBackedMap.(FileBackedMap.java:33)
        at com.ca.devtest.util.collections.FileBackedMap$FileBackedMapBuilder.build(FileBackedMap.java:154)
        at com.ca.sv.vsbuilder.VSBuilderSessionCatalog.(VSBuilderSessionCatalog.java:126)
        at com.ca.sv.remote.VSBuilderImpl.(VSBuilderImpl.java:91)
        at com.itko.lisa.coordinator.VirtualServiceEnvironmentImpl.initializeVirtualServiceCreator(VirtualServiceEnvironmentImpl.java:401)          at com.itko.lisa.coordinator.VirtualServiceEnvironmentImpl.(VirtualServiceEnvironmentImpl.java:393)
        at com.itko.lisa.coordinator.VirtualServiceEnvironmentImpl.main(VirtualServiceEnvironmentImpl.java:226)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498) at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
        at com.install4j.runtime.launcher.UnixLauncher.main(Unknown Source)
Environment:
All supported releases of DevTest
Cause:
What can cause this issue is a corrupted file under the the $DEVTEST_HOME/vsBuilderSessions/VSE_2013 folder in the VSE Server. Or if exists lisa.user.properties file, then under the folder <dataDirectory_path_Mentioned_In_lisa.user.properties_file>/vsBuilderSessions/VSE_2013
Resolution:
On the VSE server, make sure the VSE is not running and rename the VSE_2013 folder under $DEVTEST_HOME/vsBuilderSessions. Or if exists lisa.user.properties file, then rename VSE_2013 under the folder <dataDirectory_path_Mentioned_In_lisa.user.properties_file>/vsBuilderSessions/
Restart the VSE Service.
The VSE_2013 folder will be recreated when the VSE starts.