Remote Viewer Slow Login Connection Performance

Document ID : KB000044601
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem: 

We utilize a very secure network for connections to outside networks and another more open network for our user base. Our AP servers are on the more secure network. Firewall rules are in place to allow communication on Port 5500 from the user network to the secure network. When a Remote Viewer connection is initiated it can take any where from 1 - 5 minutes for the connection to be established. Wireshark sniffers show the initial communication on Port 5500 happens quickly and successfully but then the server/application appears to be requesting NetBIOS info and does this over and over. At some point it gives up on this and establishes communication on Port 5500 and the Remote Viewer connection is completed. After that everything is fine and there is no delay or slowness. Is NETBIOS communication required for Remote Viewer on UDP 137/138?

Environment:  

All Supported Windows Server environments

Cause: 

The issue is caused by the behavior of Windows Servers using NetBIOS, as well as DNS to resolve IP addresses using gethostbyaddr() Windows API in the CA Automation Point source (the Remote Manager component, specifically). The NetBIOS communication is causing the delay in the connection, so you can simply turn off NetBIOS to resolve the problem.

Resolution:

  1. From the Network and Dial-up Connections icon in Control Panel , select Local Area Connection and right-click Properties .

  2. On the General tab, click Internet Protocol (TCP/IP) in the list of components, and click the Properties button.

  3. Click the Advanced button.

  4. Click the WINS tab. Click Disable NetBIOS over TCP/IP .

Additional Information:

See this Microsoft TechNet article for more information about disabling NetBIOS over TCP/IP