Relationship viewer is not accesible

Document ID : KB000045521
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue:

 

After configuring Topology and Root Cause Analysis you open the Relationship Viewer portlet.

You see the following error: "Error connecting to server. Please contact administrator"

 

Environment:  

 

UIM 8.x or higher.

 

Cause: 

 

The relationship viewer portion of the wasp cfg is either not pointing to the correct location or is not accessible via the network. This article assumes that we have already configured every step listed in Topology and Root Cause Analysis.

 

Resolution:

 

1. Open your wasp.cfg on your UMP machine.

2. Change the following key "GraphServiceHost" to point to your primary hub's ip address.

<relationshipviewer>
<uncrypted>

GraphServicePort = 8182
GraphServiceHost = Ip_of_primary_Hub
</uncrypted>
</custom>
path = /relationshipviewer
</relationshipviewer>

 

3. Restart UMP and the error should resolve.

 

Additional Information:

 

Topology and Root Cause Analysis