Re-installation of NetQoS product completes, but not all components are installed.

Document ID : KB000005361
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

In working to perform a clean installation of ADA, NFA, or UCM, you have uninstalled the products and are re-installing them.  However, after completion of the install, you may receive errors.  These errors may be:

1. Unable to open the contact the MySQL server instance.

2. Unable to install a component as another pre-requisite NetQoS component is missing even though it is currently installed and functioning properly (ie installing the Flow Cloner on a working NFA Harvester).

Environment:
Windows Server 2008 R2Windows Server 2012 R2
Cause:

There is a hidden folder in the Program Files (or Program Files (x86) directory) called "Zero G Registry".  During some installations, the contents of the folder may be corrupted.  When this happens, the installation package is unable to properly determine what has already been installed and does not function as expected.

Resolution:

After uninstalling the NetQoS products, be sure to check for and remove this folder in the Program Files or Program Files (x86) directory.  Any subsequent installations will recreate that folder and its contents to properly track those installations.

Additional Information:

If the problem still exists, after removing this directory and performing a clean installation, please contact Support at http://support.ca.com or by calling 800-225-5224.