Registry is not starting in DevTest 9.1 with My SQL server DB

Document ID : KB000004597
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Receiving error below when starting Registry connecting to MySQL database

 

2016-10-25 19:56:18,768Z (15:56) [main] ERROR com.itko.lisa.utils.JpaUtil    - ==== #################################### ====

2016-10-25 19:56:18,768Z (15:56) [main] ERROR com.itko.lisa.utils.JpaUtil    - Connection to the registry database cannot be established.  Please make sure the database is running and the credential used to connect to database is valid. 

2016-10-25 19:56:18,768Z (15:56) [main] ERROR com.itko.lisa.utils.JpaUtil    - ==== #################################### ====

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - Connection to the registry database cannot be established.  Please make sure the database is running and the credential used to connect to database is valid. 

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - java.lang.RuntimeException: Connection to the registry database cannot be established.  Please make sure the database is running and the credential used to connect to database is valid. 

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - at com.itko.lisa.utils.JpaUtil.<init>(JpaUtil.java:516)

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - at com.itko.lisa.utils.JpaUtil.getDradisUtil(JpaUtil.java:406)

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - at com.itko.lisa.dradis.comm.JpaUtilWrapper.getAnnotations(JpaUtilWrapper.java:24)

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - at com.itko.lisa.dradis.comm.DradisCommContext.doEnterpriseDashboardHandshake(DradisCommContext.java:138)

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - at com.itko.lisa.coordinator.TestRegistryImpl.<init>(TestRegistryImpl.java:338)

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - at com.itko.lisa.coordinator.TestRegistryImpl.main(TestRegistryImpl.java:2403)

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - at java.lang.reflect.Method.invoke(Unknown Source)

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

2016-10-25 19:56:18,783Z (15:56) [main] ERROR System.err                     - at com.exe4j.runtime.WinLauncher$2.run(Unknown Source)

2016-10-25 19:56:18,799Z (15:56) [Thread-7] INFO  com.itko.lisa.net.ActiveMQFactory - Closing AMQ connections

Environment:
Database - MySQL;DevTest - 9.x;Registry and database on two separate machines
Cause:

The database was not allowing outside connections

Resolution:

Updated the database to allow outside connections from the Registry machine.

 

Additional Information:

None