Registry is going down after the test case/suite deployed and ran for a few hours

Document ID : KB000047007
Last Modified Date : 14/02/2018
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Issue/Problem/Symptoms:

- Registry went down. The coordinator logs show the error below:

com.itko.lisa.history.LoadHistoryWriteSupport.events - Got warning/error event : CompareLiveRespone,CompareLiveRespone [Run1User1Cycle],494,11,Web Service ship,27D8CB737F0211E6B671808220524153,Step warning,Thu Sep 22 06:05:31 GMT 2016,SimulatorOverloaded,Sleep for 751 actually took 1790

Environment:

- DevTest 9.0 distributed environment

Cause:

- The issue occurred due to heavy load on simulator. One simulator can handle 256 instances at the max and it can go down depending on the hardware of the machine where simulator is running. Test cases/suites were staged with load more than one simulator can handle the load.

Resolution/Workaround:

-      Ensure you do not put load more than your simulator could handle. Please refer to the article below to know how to calculate the number of instances your simulator could handle.

              https://docops.ca.com/devtest-solutions/9-0/en/installing/installing-and-configuring-devtest-server/post-installation/calculate-simulator-instances

For any further assistance with respect to performance tuning, please contact CA services via your CA Account Manager.