Rediscovering routers gives error 'The request failed http status 404: Not Found' in RA 9.0

Document ID : KB000021733
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem: 

Trying to rediscover routers through the RA web gui gives the following error:

The request failed with http status 404: Not Found

This only impacts RA 9.0.

 

Resolution:

This is caused by .NET 2.0 not being allowed in the IIS configuration. To resolve, follow these steps:

RDP to each Harvester server, or the RA standalone server.

  • Right-click on My Computer and select Manage

  • Go to Internet Information Services (IIS)

  • Expand web service extensions

  • Select ASP.NET v2.0, ASP.NET v1.1, and Active Server Pages and then hit Allow

    Figure 1

  • Open a command prompt on the server

  • Run the following two commands:

    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -r

    iisreset

Then refresh the enable interfaces page and try it again.

Note: For Win 2008, IIS v7 the 'Web Service Extensions' are located under IIS Manager >Server Name then in the icons on the right click on 'ISAPI and CGI Restrictions'

 

Additional Information: 

Please note that RA 9.0 is end of life and you should consider upgrading to ensure that you are running a supported environment.

https://www.ca.com/us/services-support/ca-support/ca-support-online/product-content/status/support-life-cycle/ca-network-flow-analysis-r9_1-sp1-r9_1-ca-netqos-reporteranalyzer-r9_0-sp1-r9_0-eos-announcement.html