VSE Recorder using Proxy mode is not working

Document ID : KB000115796
Last Modified Date : 06/12/2018
Show Technical Document Details
Issue:
Recording through proxy not working in DevTest.
Environment:
DevTest on release 10.3.
Cause:
To be able to reach to the endpoint it is necessary to configure a proxy on your environment.
Without the proxy settings, the Workstation would time out and not be able to get to the endpoint.
Resolution:
The following properties need to be configured in the Workstation local.properties file with the proxy information of your environment:

## ============================================== 
## HTTP Proxy Server 
## ============================================== 
lisa.http.webProxy.host=<MACHINE NAME OR IP ADDRESS> 
##list of excluded machine names or ip addresses delimited by pipes, * wildcard accepted <machine name or ip>[|<machine name or ip>]* 
#lisa.http.webProxy.nonProxyHosts=127.0.0.1 
lisa.http.webProxy.port=<PORT>

## ============================================== 
## HTTPS Proxy Server 
## ============================================== 
lisa.http.webProxy.ssl.host=<MACHINE NAME OR IP ADDRESS> 
##list of excluded machine names or ip addresses delimited by pipes, * wildcard accepted <machine name or ip>[|<machine name or ip>]* 
#lisa.http.webProxy.ssl.nonProxyHosts=127.0.0.1 
lisa.http.webProxy.ssl.port=<PORT>

The Workstation needs to be restarted after the properties file is updated.

Since you are using DevTest 10.3, you should be able to capture the traffic using the Gateway pass thru style as well.
This is a new feature with this release. Before 10.3 we would need to use the Proxy pass thru style.
With 10.3 it was added support for web proxy in gateway recorder - https://docops.ca.com/devtest-solutions/10-3/en/release-notes/new-features-and-enhancements#NewFeaturesandEnhancements-SupportProxyserversforrecordinginGatewaymode-RecordingMode
Additional Information:
If you already have the proxy settings in the local.properties and is still facing issues to reach the endpoint, please refer the document in the link below:
local.properties is updated with proxy details but Workstation is not able to reach the endpointhttps://comm.support.ca.com/kb/localproperties-is-updated-with-proxy-details-but-Workstation-is-not-able-to-reach-the-endpoint/KB000009145